Jan
10
2018

Cisco EIGRP named, a better approach

The Enhanced Interior Gateway Routing Protocol can be configured using either the classic mode or the named mode. The classic mode is the old way of configuring EIGRP. In classic mode, EIGRP configurations are scattered across the router mode and the interface mode. The named mode is the new way of configuring EIGRP; this mode allows EIGRP configurations to be entered in a hierarchical manner under the router mode.

Each named mode configuration can have multiple address families and autonomous system number combinations. In the named mode, you can have similar configurations across IPv4 and IPv6.

Although Named EIGRP is configured differently from traditional EIGRP, the configurations are compatible, meaning that an EIGRP-speaking router configured with the traditional approach can form a neighborship with an EIGRP-speaking router configured with the Named approach.

There are three configuration modes in named EIGRP:

  • Address-Family: to configure networks, EIGRP neighbor, EIGRP Router-id, metric etc.
  • Address-Family-Interface: to configure all the interface specific commands that were previously configured on an actual interface (logical or physical) and moves them into the EIGRP configuration. For instance EIGRP authentication, split-horizon, summary-address configuration etc.
  • Address-Family-Topology: to provide several options which operates on EIGRP topology table. For instance redistribution, distance, offset list, variance etc.

To better understand how named EIGRP works suppose that you want convert this classic eigrp configuration to the named eigrp configuration.

Classic EIGRP configuration:

int Gi0/0
 ip add 192.168.1.1 255.255.255.252
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 ciscozine-key
 ip hello eigrp 100 12
 ipv6 address 2003::1/64
 ipv6 eigrp 200

router eigrp 100
 network 192.168.1.0 0.0.0.3
 passive-interface default
 no passive-interface Gi0/0
 distribute-list prefix Ciscozine-PREFIX in
 redistribute connected

ipv6 router eigrp 200
 variance 2 

router eigrp 300
 address-family ipv4 vrf Cisco-VRF
 network 0.0.0.0 0.0.0.0

 

Named EIGRP configuration:

router eigrp Ciscozine

 address-family ipv4 unicast autonomous-system 100
  network 192.168.1.0 0.0.0.3

 af-interface default
  passive-interface
  exit-af-interface 

 af-interface Gi0/0
  no passive-interface
  authentication mode md5
  authentication key-chain ciscozine-key
  hello-interval 12
  exit-af-interface

 topology base
  redistribute connected
  distribute-list prefix Ciscozine-PREFIX in
  exit-af-topology
 exit-address-family

 address-family ipv6 unicast autonomous-system 200
  topology base
   variance 2
   exit-af-topology
  exit-address-family

 address-family ipv4 unicast vrf Cisco-VRF autonomous-system 300
  network 0.0.0.0 0.0.0.0
 exit-address-family

Remember: Even though Named EIGRP is configured differently than traditional EIGRP, the show commands remain the same.

Note: The EIGRP named configuration is available from these releases:

  • 15.0(1)M
  • 12.2(33)SRE
  • 12.2(33)XNE
  • Cisco IOS XE Release 2.5

Note: From IOS 15.4(2)T or IOS XE 3.11S, Cisco has introduced the “eigrp upgrade-cli” command. This feature permits to upgrade EIGRP “classic mode” configurations to named mode without causing network flaps or requiring EIGRP process restart. After conversion, the show running-config command will show only named mode configurations; you will not see any old classic mode configurations.

References: https://www.cisco.com/…/200156-Configure-EIGRP-Named-Mode.html

Summary
Cisco EIGRP named, a better approach
Article Name
Cisco EIGRP named, a better approach
Description
The Enhanced Interior Gateway Routing Protocol can be configured using either the classic mode or the named mode. The classic mode is the old way of configuring EIGRP. In classic mode, EIGRP configurations are scattered across the router mode and the interface mode. The named mode is the new way of configuring EIGRP.
Author